Jump to content
iFxWolf

Hilux 5L leaking piston rings?

Recommended Posts

iFxWolf

On the weekend I repaired a gas leak from the manifold but in doing so noticed the oil leak I thought was from the rocker cover (also repaired) was in fact also coming out of the first cylinder exhaust port, 

4 diesel soot

3 diesel soot

2 alittle oil but mostly soot

1 all oil no soot 

radiator

 

my guess is the head wasn’t repaired right or the piston rings are shot??

 

iv done oil changes every 5000 miles but Iv not had it too long, 

 

so the mileage is now 341600km

as far as I know it’s never been rebuilt,

what should I do? Keep driving it till it go’s bang or rebuild it using a unbranded kit? Or do a swap?

 

 

Share this post


Link to post
Share on other sites
twincabsteve

So is it an oily exhaust port, could it just be valve stem oil seals ? A compression test would tell if it's rings. Don't drive it till it goes bang coz these engines are hard to get hold of and worth a bit if sold on. 

I've just put one in my mk4 and turbo'd it. They respond very well to a turbo :thumbsup:

Share this post


Link to post
Share on other sites
lastofthev8s

Sounds more like stem oil seals. Does it blue smoke on start up or while accelerating? 

Share this post


Link to post
Share on other sites
iFxWolf
8 hours ago, twincabsteve said:

So is it an oily exhaust port, could it just be valve stem oil seals ? A compression test would tell if it's rings. Don't drive it till it goes bang coz these engines are hard to get hold of and worth a bit if sold on. 

I've just put one in my mk4 and turbo'd it. They respond very well to a turbo :thumbsup:

Well it had a new or rebuilt cylinder head when I got it,  so I can’t tell but it could very well be a cheap cylinder head from eBay, 

It’s because of me being unsure about weather or not it was skimmed or replaced which is why it hasn’t been turboed,

7 hours ago, lastofthev8s said:

Sounds more like stem oil seals. Does it blue smoke on start up or while accelerating? 

Mmm it does put out a big puff of gray smoke when you start it but then clears right away, 

 

when driving its alittle smoky but only noticeable in the dark when someone with them crazy bright leds are behind, it also pops out a big puff of smoke at 50/60mph, 

 

the injectors are knackered also, I’m hoping when my forwarder moves job the harvester lad can pick me up in the morning so I can get them out and rebuilt.

Share this post


Link to post
Share on other sites
lastofthev8s

When srem oil seals fail you can expect a little bit of smoke while driving but the dead give away is usually on start up when the engine has been sat long enough to allow oil to collect in the ports. 

Smoking only under acceleration usually points towards piston rings cause the oil works its way past the rings and into the cylinder. 

One step at a time anyway, get your injectors sorted first then see where you're heading. It's not uncommon for bad injectors to wash the cylinders of their oil which wears the bore and the rings. :unsure:

 

Share this post


Link to post
Share on other sites
iFxWolf
6 minutes ago, lastofthev8s said:

When srem oil seals fail you can expect a little bit of smoke while driving but the dead give away is usually on start up when the engine has been sat long enough to allow oil to collect in the ports. 

Smoking only under acceleration usually points towards piston rings cause the oil works its way past the rings and into the cylinder. 

One step at a time anyway, get your injectors sorted first then see where you're heading. It's not uncommon for bad injectors to wash the cylinders of their oil which wears the bore and the rings. :unsure:

 

Ok I’ll get the injectors done first, how much would you expect to pay for a engine rebuild kit? 

 

Theres 1 on eBay for the 5L that has everything even the piston and rings, tho it’s only £200 which puts me off and it’s unbranded, 

Share this post


Link to post
Share on other sites
iFxWolf

Oh and I’m not sure if it’s worth saying but my mpg is really bad now, 

Share this post


Link to post
Share on other sites
lastofthev8s
5 hours ago, iFxWolf said:

Ok I’ll get the injectors done first, how much would you expect to pay for a engine rebuild kit? 

 

Theres 1 on eBay for the 5L that has everything even the piston and rings, tho it’s only £200 which puts me off and it’s unbranded, 

Could be the same kind of kit I was looking at for the 3L (from dubai?) 

Hard to say when we don't know what you actually need, your bores and pistons might be fine so you'd only need rings, bearings and gaskets. 

Share this post


Link to post
Share on other sites
twincabsteve

Got to get it compression tested to say for sure if it's rings. Pointless tearing it apart if you don't need to coz it will get costly. I ordered a blueprint gasket set through my local motor factors only thing I was having problems with was I didn't have the reg number of engine for easy of ordering. But yours is in original truck so should be straight forward. Other than head gasket and internal components most other parts are shared with the L series engines and are interchangeable.

Share this post


Link to post
Share on other sites
iFxWolf
46 minutes ago, lastofthev8s said:

Could be the same kind of kit I was looking at for the 3L (from dubai?) 

Hard to say when we don't know what you actually need, your bores and pistons might be fine so you'd only need rings, bearings and gaskets. 

Yes!! It’s the only thing I can find that isn’t like £1000

 

so get it all tested first?

13 minutes ago, twincabsteve said:

Got to get it compression tested to say for sure if it's rings. Pointless tearing it apart if you don't need to coz it will get costly. I ordered a blueprint gasket set through my local motor factors only thing I was having problems with was I didn't have the reg number of engine for easy of ordering. But yours is in original truck so should be straight forward. Other than head gasket and internal components most other parts are shared with the L series engines and are interchangeable.

I think with the mileage it’ll be needing a rebuild, 

 

ill get it tested, 

 

how fast is is your truck with the turbo? As the normal 5l seems pretty gutless when you get to the hills or towing

Share this post


Link to post
Share on other sites
iFxWolf

Ordered a diesel compression tester will update when I get it,

 

no no idea what I’m looking for in psi

Share this post


Link to post
Share on other sites
twincabsteve

Not sure on psi's but they should all be similar readings. So as you say no1 is burning no oil and no4 is and they compression test with very close readings then it's not rings or they'd both have oil if you get me. I'm sure the manual that's available on this forum  will have readings. I used it when doing the head rebuild on mine.

As for how fast, my original 2.4 to had 3inch exhaust, intercooler, boost wound up to 14psi. Max fuel screw wound in and aneroid turned to deepest setting and this 3.0 5L  is quicker that that with standard fueling and 10psi of boost. But has the 3inch exhaust and intercooler.

Last weekend I turned the aneroid to its deepest setting and it flies and hills are no problem and I'm on 35's with stock diffs :thumbsup:

http://www.hpoc.co.uk/documentation/mk4/5L-ENGINE.zip

  • Upvote 2

Share this post


Link to post
Share on other sites
4x4steve

alot of questions unanswered when you read tho it, 

the smoke you describe i would say is normal, visible smoke  on acceleration when being folowed by some audi with his searchlights on is normal i would say, same as smoke on start up, are you sure its not oil coming from the front corner where alot seem to leak, main oil way or somat else leaks there on a few i have seen 

Share this post


Link to post
Share on other sites
iFxWolf
6 hours ago, 4x4steve said:

alot of questions unanswered when you read tho it, 

the smoke you describe i would say is normal, visible smoke  on acceleration when being folowed by some audi with his searchlights on is normal i would say, same as smoke on start up, are you sure its not oil coming from the front corner where alot seem to leak, main oil way or somat else leaks there on a few i have seen 

I fitted a new rocker cover seal, because it was leaking pretty badly, 

the oil from the cover couldn’t leak into the exhaust port could it? 

Share this post


Link to post
Share on other sites
4x4steve

Ah. So its deffo  internal leak.  Then i would agree with whoever said stem oil seals

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×